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[bookmark: _heading=h.kttpd5l9d1wd]

Navigation and Order								
Navigate To the Ends of the Worksheet
1. [bookmark: _heading=h.nbfx7e2lhvv7]Hold down Ctrl and Shift while pressing any of the four directional arrows to get to the top, bottom, leftmost, or rightmost edges of your screen. 
*Note that this works best in columns/rows without blank values. If the column or row has some values and some blanks, this will just navigate you to the next blank cell.
[bookmark: _heading=h.nushxiw5gmqm]Reorder Columns or Rows by Dragging:
1. Select a row or a column as you would normally do (by clicking the row number or column letter).
2. Hold down the shift key and hover over the border of the row or column header (at the edge of the column or row header and the active cell next to it) until you see the four directional arrows. 
[image: ]
3. Now drag your row or column where you want it and release the mouse button.
[bookmark: _heading=h.kbi480lc8g9]Drag to Populate Cells
1. Select the cell you want to use to copy from. 
2. Notice the tiny dot in the bottom right corner of the cell.
3. Hover over the dot until you get a small black plus sign[image: A picture containing application

Description automatically generated]
4. Drag down over the cells you want to paste to. 
**This works just like a regular copy paste, so if you are copying and pasting formulas, Excel will behave in the same way it would if you copied and pasted in the normal way.
**Most of the time when you have the small black plus sign you can double click and it will auto-fill your formula. This doesn’t always work depending on what you try to auto fill.
[bookmark: _heading=h.c58ht9eko1ky]Advanced Pasting
1. Once you have copied some cells, click on the arrow below the big Paste button. 
a. [image: Graphical user interface, application, email

Description automatically generated]This allows you to see all of the paste choices. 
2. You have lots of options, most of which are covered here: https://support.microsoft.com/en-us/office/paste-options-8ea795b0-87cd-46af-9b59-ed4d8b1669ad  
**You can include column widths, paste cells copied in a horizontal relationship vertically, paste formula-derived cells with their text (plain text or formatted text) values, and more.
[bookmark: _heading=h.qxfkpjz10ydg]

Sort and Filter	
[bookmark: _heading=h.oqhpf9bipfh6]Reorder Columns with the Sort Function.
1. Select the area that you want to reorder. 
a. If you have column headers for the data, include them in your selection.
2. Right click on the selection, select the Sort submenu, and select Custom Sort... 
a. A popup window will appear. 
3. Click the Sort by… field to choose primary sort column. 
a. If you have selected column headers, make sure that the checkbox next to My data has headers is checked.
[image: Graphical user interface, text, application

Description automatically generated]
4. If you want to sort by multiple columns, you can click the Add Level button. 
a. Click OK when you are done.
**What if you need your columns in an order that doesn’t follow the numeric or alpha order in your data? Cheat!
1. In a blank column next to your data, type numbers with the order you want your data to appear in.
2. Select the data, including the column you just populated. 
3. Right-click and choose Sort and then Custom Sort... Sort using your new column.
4. You can delete the data you used to sort once you are done (or keep it).
[bookmark: _heading=h.f92uxuf1hene]Using the Filter Function
1. This only works well if your data has column headers. 
2. Make sure the selected cell is in the header row, and then click Filter under the Data menu. 
a. A dropdown arrow will appear next to each column header.
3. Click on it to see all of the unique values in the column. 
a. This is handy for checking to make sure you have clean data and the range of values you expect in that column.
4. You can then click the checkboxes next to the values you want to select. 
a. You can very quickly get counts of each type of value at the bottom of the screen.

[image: Text

Description automatically generated]
**Be careful! Merged cells can confuse the filtering functions, so you have to make sure you have a pretty simple layout on your data set when you are relying on filtering to provide a good count.
[bookmark: _heading=h.kf7yxgvi2gc8]

Manage What Data Shows			
[bookmark: _heading=h.xxepdbfgaatu]Create A Dropdown List For A Cell.
1. Create a list of the values you want to appear in your dropdown by entering them in cells. I recommend putting them in a separate worksheet and making it clear what they are.
[image: Table

Description automatically generated]
2. Select the cell or cells where you would like the dropdown to appear. 
3. Under the Data menu, within the Data Tools section, select Data Validation. [image: A picture containing icon

Description automatically generated]
a. You may only see an icon with a green checkmark above a red circle slash.
b. A pop-up window will appear. 
4. Under the Allow field, select List. 
5. Then click the arrow to the right of the Source field. 
a. This shrinks the popup window while you go back to your list of values.
[image: Graphical user interface, application

Description automatically generated]
6. Navigate to your list of values and select the cells. 
a. The range of cells should appear in the Source field.
7. Click the arrow to the right of the Source field again to expand the window so that you can click OK.
8. When you go back to your selected cell, you will see a dropdown field appear as soon as that cell is selected.
[bookmark: _heading=h.8z9dsvinvfn2]Highlight Duplicate Values
1. If you are checking data integrity, you will likely want to make sure that your unique identifiers are really unique. You can do this very easily!
2. There are two ways to do this. 
3. First, you can color code duplicates if you don’t want to alter data and just want to check for duplicates. 
a. Highlight the column and then under the Home menu
b. Click the Conditional Formatting button. 
c. Select the Highlight Cells Rules
d. Click Duplicate Values
e. Click OK. 
f. All of the cells with duplicate values will be highlighted.
4. You can use a different method if that works better for you. 
a. Highlight the column and click the Data menu. 
b. In the Data Tools section of the submenu, is a selection Remove Duplicates. 
c. When you click this, duplicates will be deleted, and the number of duplicates will be reported to you.
d. If you are wondering which duplicates are deleted, Excel keeps the first instance of each dup and deletes the rest.
[bookmark: _heading=h.k1n0vyerdqr3]Freeze Panes
1. To freeze either the top row or the first column of your spreadsheet so that you can always see them as you scroll, go to the View menu, and click Freeze Panes under the Window section. 
2. If you want to freeze both rows and columns, select the first cell that SHOULDN’T be frozen. 
3. In the example below, if you wanted to make sure you could always see the top row AND the Segment column, you would select the cell highlighted in yellow. Then, under the Freeze Panes tool, select Freeze Panes.
[image: Table

Description automatically generated]

4. Once you have frozen sections of your sheet, the Freeze Panes tool will show an option to Unfreeze Panes and go back to a normal view.
[bookmark: _heading=h.49ymnz9l7ix2]Advanced Hiding/Unhiding of Groups of Columns or Rows
If you are working in a sheet where you are regularly hiding and unhiding the same group of columns or rows, you can group them to create a shortcut for easily hiding and unhiding.
1. Select your rows/column.
2. Under the Data menu, select Group from the Outline section.
3. Notice that once you select Group, Excel shows you a box with a minus option in it just above and to the right of the rightmost column you selected.
[image: ]
4. Click the – in the box to hide the entire group of columns. Notice that the box now contains a plus. Click it again to show the group of columns.
5. If you want to get rid of that grouping, you can select the Ungroup option from the same menu.
[bookmark: _heading=h.ogxigldu55oq]Get the Zeros in your CDS Codes to Stick!
Don’t you just hate it when excel drops the leading zero! Or makes your CDE code look like a formula?[image: ]
1. Select the column (or cells) you want to format
2. Click CTRL and the 1 key (or right click and format cells)
3. Go to custom
4. Type 14 zeroes into the box (or 2 for the county portion, 5 for the district portion, 7 for the school portion.)
[image: ]
**This also gets any leading zeroes to stay!
[bookmark: _heading=h.jdgz1s38j5ol]Take A Column and Split The Values Into Two Columns
Say you want to take a column and split it up, but the number of characters might vary. For example, you might want to take a name and split it into first name and last name columns. In the example below I have a column where a lot of the data might be names, divided by a comma. I want to try and put those fields into separate Last Name and First Name columns. I added some blank columns in the example below to hold the results.

[image: Table

Description automatically generated]
1. Select the cells you want to split up. Under the Data menu, select Text to Columns.
2. Excel will walk you through a wizard. Because we are splitting our values up based on a comma, we will select Delimited. You can also use this with a space character! 
3. Click Next.
4. You will then need to tell Excel what your delimiter is. In our example, you would select Comma.
[image: Graphical user interface, application, Word

Description automatically generated]
5. The last step asks you to define the format of the data (General is fine for text) and the Destination. We will make sure the Last Name column appears there: $E$2. You can type this in or select it in your worksheet. Click the Finish button. Notice that where commas were found, the cells were split up appropriately into last name and first name columns. When the comma wasn’t found, the entire value was put into the Last Name column, and a blank was put into the First Name column.
[image: Table

Description automatically generated]
[bookmark: _heading=h.t5npo6vkpyl]Add Up Values
[bookmark: _heading=h.srz15kck5wry]Autosum
1. Select the cell where you would like your total. Autosum will work on horizontal groups of cells OR vertical groups.
2. Under the Home menu, within the Editing section, click on the Sigma. Sum is the first and default choice, but notice there are some other options there.
[image: ]
3. Autosum will make its best guess on whether you want a total based on a vertical column directly above or a horizontal row adjacent to the active cell. If there might be some confusion, make sure you check and see what it is actually doing. (See next trick!)
[bookmark: _heading=h.1uxlv29anxw8]Autosum Super Cheat
1. Select the cell where you would like your total. Autosum will work on horizontal groups of cells OR vertical groups.
2. Hit ALT and the = key
3. Excel will autosum for you!
[bookmark: _heading=h.e745h4eteadw]

Formulas
[bookmark: _heading=h.im7g2c3nqfxh]Check Formula
1. A good way to make sure a formula is using the right cells in its calculation is to place your cursor into the edit field. Select the cell containing the formula, and then place your cursor in the editing field:
[image: Graphical user interface, application, table, Excel

Description automatically generated]
2. Notice that when you do that, the fields that are used to calculate the cell are highlighted in different colors, making this an easy way to check and make sure the right cells are included in a calculation.
[image: A screenshot of a computer

Description automatically generated with medium confidence]
[bookmark: _heading=h.2zd6jwn704o7]Using Dollar Signs in Formulas
You may have noticed that when you copy and paste formulas, Excel automatically changes the calculation references so that they are relative to where you are pasting them. For example, I want to calculate the percentage of each gender category below, and to do this I am dividing the number of male students by a sum of the three gender categories.
[image: Table

Description automatically generated]
But when I copy the formula into the next row, look what happens:
[image: A picture containing application

Description automatically generated]
Excel assumes that because I am copying to the next row, all of the cells I used in my formula should also move one row down. I am glad that Excel assumes my numerator will move one cell down, but I don’t want it to mess with my denominator!

To signal to Excel that you want to anchor parts of your calculation to a constant cell, use a dollar sign $ in front of the column letter, the row number, or both. In the example below, I don’t touch my numerator, because I was happy to have that referencing the current row. In my denominator, I put dollar signs in front of the column letter and row numbers in my sum so that portion of the calculation would not change. Then, when I copied the formula calculating the percentage of males to my other rows, the percentages were correctly calculated.
[image: Chart

Description automatically generated with medium confidence]  
**You can use the F4 key to toggle between where the $ go, very easily!
[bookmark: _heading=h.pz47lyojxedp]Ctrl-~ to display formulas instead of values
You can display all of the formulas in a worksheet instead of the values by pressing Control-~. Use Control-~ once more to toggle back again. This is handy for checking to make sure formulas are correct but also to ensure that you have formulas in all the right cells (instead of numeric values).
[bookmark: _heading=h.vgaf93f81xej]

Advanced Stupid: Functions
There are dozens of functions you can use in Excel, and many of them can help when you have a very particular need.
[bookmark: _heading=h.so1a9bpi8rux]PROPER Function
The PROPER function take a text value and capitalizes every word:
[image: Graphical user interface, text, application, website

Description automatically generated]
=lower makes everything lower case
=upper makes everything capitalized
[bookmark: _heading=h.nuiq8as7kt7h]SUM Function
The SUM function adds up cells (vertically or horizontally):
[image: Graphical user interface

Description automatically generated with medium confidence]
[bookmark: _heading=h.p4xjl4tgmx0k]IF Function
The IF function can do two different actions based on whether the condition is true or false. For example, say you want to identify rows based on whether an order was placed inside the US or outside.
1. Select the cell where you want your result.
2. Type in your formula, which tells Excel: If Cell B2 equals “United States of America”, then this cell should say “America”; otherwise, this cell should say “NOT AMERICA.”
[image: Graphical user interface, text, application

Description automatically generated]
[bookmark: _heading=h.7lt9ffd9qvpz]CountA Function
Counts non-blank cells in the selection.
=counta(A:A) will count all of the non-blank cells in column A
[bookmark: _heading=h.1r7djs3tdu4g]CountIF Function
Counts the cells of a certain value. I like to put my values in the cell next door instead of typing them in. In the below example, my data for each question was in columns A, B and C.
[image: ]
[bookmark: _heading=h.53wu6krynltu]LEFT, RIGHT, and MID Functions
Sometimes, you want to take a large field and split it into smaller pieces. You can use LEFT, RIGHT, and MID. In the example below, I have a huge CDS code, which is the way the CDE identifies schools. CDS Codes are made up of county codes, district codes, and school codes, all strung together. I want to get the three parts of the CDS code and put them into separate columns.
The first two characters of a CDS Code are the county code. Using the LEFT function, I am telling Excel to take Cell I19 (the full CDS Code) and give me the first 2 characters on the left. This produces a 34 on the row below. The District Code is the next 5 characters in the CDS Code. I am using the MID function to tell Excel to take Cell I19 and starting at character 3, give me the next 5 characters. I get the “10348” which is the district code. The last seven characters are the school code, so I use my RIGHT function to ask Excel to give me the last 7 characters of Cell I19, which is the School Code “0106278”.
[image: Application, table

Description automatically generated]
[bookmark: _heading=h.hoeqk2lf6hh7]Concatenate
Combines values from different cells into one. There is an actual concatenate formula you can use, but I prefer this shortcut:
1. the formula is =A1&” “&B1&” “&C1
2. This will combine them. So if you had 
a. Do in A1
b. Re in B2
c. Me in C1
d. The cell where you did this formula will have Do Re Me 
3. You can also delete spaces, add commas, etc between what you combine
a. In my example above I put a space between the “ “
b. Delete the space and there will be no space in your combined values
c. Add a comma and a space and that will what will show between values
4. Great for combining names, especially if you just used Text to Columns to separate names
a. When names are last, first I will use Text to Columns to separate then this formula to recombine
[image: ]
[image: ]
[bookmark: _heading=h.wysae07pc58b]Round Function
Will round the value to a certain decimal place. Great for budgets or data that deals with money, but plenty of other uses!
=ROUND(A1,2) will round cell A1 to 2 decimal places. You can control how many places it rounds to with the second value.
[bookmark: _heading=h.sf5p1tjvalsv]Truncate
Will cut off the value after a certain point without rounding!
=TRUNC(A1,1) will truncate the value in cell A1 to 1 decimal place without any rounding. You can control how many places it truncates to with the second value.
[bookmark: _heading=h.hue1gfzg4l8]

Chart Tricks											
[bookmark: _heading=h.qho9q8yhdska]Chart Templates
If you find yourself making the same types of changes to your charts over and over, you should save yourself the trouble and create Chart Templates. 
1. After you have inserted and made your basic changes to your chart, right click on it and select Save as Template…
2. You save a template just like you would a file, so make the file name descriptive. 
3. Once you save it, when you go to insert a chart, you can use one of your pre-made templates instead. Here’s how:
a. After you select the data and want to insert a chart using the Insert menu
b. Click Recommended Charts under the Charts section. 
c. Click the All Charts tab. 
i. Notice there is a Templates folder available. 
d. Click on it to view your templates, then select the one you want to use.
[image: Graphical user interface

Description automatically generated]
[bookmark: _heading=h.hy290718ui8r]Copy / Paste Chart Formats
You can copy / paste the set up of one chart onto another. This is great if you have small multiples!
1. Set up the first chart exactly how you want it
2. I mean EXACTLY!
3. Copy that chart (CTRL C, right click copy, however you like to copy
4. Click on the next chart
5.  Select the arrow under the paste menu on the home tab of the ribbon
6. [image: ]
7. Select Paste Special
8. Select Formats
9. Click Ok
[bookmark: _heading=h.c225kd4n3hy0]Custom Number Formats/Hiding Zeroes
Excel allows you a lot of control over how you show numbers on your chart. When you are editing your chart, you will see the raw number code within the Data Label Number section within your options for formatting data labels.
[image: Graphical user interface, text, application

Description automatically generated]
You can actually create a format code with different formatting for positive values, negative values, zero values, and text. In fact, the Format Code is really a four-part code where each section is separated by a semi colon. Here is how Microsoft explains it:
[image: Graphical user interface, text, application, email

Description automatically generated]
So, in my example, the format code is very simple: 0%
This treats every data label as a simple percentage with no decimal points.
If you wanted to show your negative values in red, your format code would be:
0%;[Red]0% (Click the Add button after you change your format code)
There may be occasions where you want data labels in your chart EXCEPT when they are zeroes. Change your format code to:
0%;[Red]0%;;
What you did there is just empty out the zero portion of the code.If you want to add plus signs to your positive values and make them green for drama:
[Green]+0%;[Red]0%;;
Sadly, only these eight colors are available: [Black] [Blue] [Cyan] [Green] [Magenta] [Red] [White] [Yellow]
These colors override any formatting you might have applied to the label, so use it sparingly.
[bookmark: _heading=h.a06r4c501ele]

Conditional Formatting								
Conditional Formatting lives on the home tab of the ribbon and allows you to format cells based on certain conditions that you set.
[image: ]
[bookmark: _heading=h.6gw1nalr84tr]Highlight Every Other Row
1. Select the data (or entire sheet) that you want the highlight to apply to
2. Select Conditional Formatting
3. Select Highlight Cell Rules
4. Select More Rules
[image: ]
5. Select Use a Formula
6. The formula is =mod(row(),2)=1
7. Select the format button
8. Pick a fill color
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